CVE-2021-22945

Double Free in conan/libcurl

Identifier

CVE-2021-22945

Package Slug

conan/libcurl

Vulnerability

Double Free

Description

When sending data to an MQTT server, libcurl could in some circumstances erroneously keep a pointer to an already freed memory area and both use that again in a subsequent call to send data and also free it again.

Affected Versions

All versions starting from 7.73.0 up to 7.78.0

Solution

Upgrade to version 7.79.0 or above.

Last Modified

2021-10-09

source