Identifier

CVE-2020-15503

Package Slug

conan/libraw

Vulnerability

Improper Input Validation

Description

LibRaw lacks a thumbnail size range check. This affects decoders/unpack_thumb.cpp, postprocessing/mem_image.cpp, and utils/thumb_utils.cpp. For example, malloc(sizeof(libraw_processed_image_t)+T.tlength) occurs without validating T.length.

Affected Versions

All versions up to 0.20

Solution

Unfortunately, there is no solution available yet.

Last Modified

2020-07-24

source