CVE-2022-29458

Out-of-bounds Read in conan/ncurses

Identifiers

CVE-2022-29458

Package Slug

conan/ncurses

Vulnerability

Out-of-bounds Read

Description

ncurses 6.3 before patch 20220416 has an out-of-bounds read and segmentation violation in convertstrings in tinfo/readentry.c in the terminfo library.

Affected Versions

All versions before 6.3

Solution

Upgrade to version 6.3 or above.

Last Modified

2022-05-01

source