CVE-2022-39224

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') in gem/arr-pm

Identifiers

GHSA-88cv-mj24-8w3q, CVE-2022-39224

Package Slug

gem/arr-pm

Vulnerability

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Description

Arr-pm is an RPM reader/writer library written in Ruby. Versions prior to 0.0.12 are subject to OS command injection resulting in shell execution if the RPM contains a malicious "payload compressor" field. This vulnerability impacts the extract and files methods of the RPM::File class of this library. Version 0.0.12 patches these issues. A workaround for this issue is to ensure any RPMs being processed contain valid/known payload compressor values such as gzip, bzip2, xz, zstd, and lzma. The payload compressor field in an rpm can be checked by using the rpm command line tool.

Affected Versions

All versions before 0.0.12

Solution

Upgrade to version 0.0.12 or above.

Last Modified

2022-09-22

source