CVE-2022-31072

Incorrect Default Permissions in gem/octokit

Identifiers

GHSA-g28x-pgr3-qqx6, CVE-2022-31072

Package Slug

gem/octokit

Vulnerability

Incorrect Default Permissions

Description

Octokit is a Ruby toolkit for the GitHub API. Versions 4.23.0 and 4.24.0 of the octokit gem were published containing world-writeable files. Specifically, the gem was packed with files having their permissions set to -rw-rw-rw- (i.e. 0666) instead of rw-r--r-- (i.e. 0644). This means everyone who is not the owner (Group and Public) with access to the instance where this release had been installed could modify the world-writable files from this gem. This issue is patched in Octokit 4.25.0. Two workarounds are available. Users can use the previous version of the gem, v4.22.0. Alternatively, users can modify the file permissions manually until they are able to upgrade to the latest version.

Affected Versions

All versions starting from 4.23.0 before 4.25.0

Solution

Upgrade to version 4.25.0 or above.

Last Modified

2022-06-17

source