CVE-2022-31071

Incorrect Default Permissions in gem/octopoller

Identifiers

GHSA-26qj-cr27-r5c4, CVE-2022-31071

Package Slug

gem/octopoller

Vulnerability

Incorrect Default Permissions

Description

Octopoller is a micro gem for polling and retrying. Version 0.2.0 of the octopoller gem was published containing world-writeable files. Specifically, the gem was packed with files having their permissions set to -rw-rw-rw- (i.e. 0666) instead of rw-r--r-- (i.e. 0644). This means everyone who is not the owner (Group and Public) with access to the instance where this release had been installed could modify the world-writable files from this gem. This issue is patched in Octopoller 0.3.0. Two workarounds are available. Users can use the previous version of the gem, v0.1.0. Alternatively, users can modify the file permissions manually until they are able to upgrade to the latest version.

Affected Versions

Version 0.2.0

Solution

Upgrade to version 0.3.0 or above.

Last Modified

2022-06-17

source