CVE-2024-24768

Cleartext Storage of Sensitive Information in a Cookie in go/github.com/1Panel-dev/1Panel

Identifiers

GHSA-9xfw-jjq2-7v8h, CVE-2024-24768

Package Slug

go/github.com/1Panel-dev/1Panel

Vulnerability

Cleartext Storage of Sensitive Information in a Cookie

Description

1Panel is an open source Linux server operation and maintenance management panel. The HTTPS cookie that comes with the panel does not have the Secure keyword, which may cause the cookie to be sent in plain text if accessed using HTTP. This issue has been patched in version 1.9.6.

Affected Versions

All versions up to 1.9.5

Solution

Upgrade to version 1.9.6 or above.

Last Modified

2024-02-06

source