CVE-2022-31105

Improper Certificate Validation in go/github.com/argoproj/argo-cd

Identifiers

GHSA-7943-82jg-wmw5, CVE-2022-31105

Package Slug

go/github.com/argoproj/argo-cd

Vulnerability

Improper Certificate Validation

Description

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Argo CD starting with version 0.4.0 and prior to 2.2.11, 2.3.6, and 2.4.5 is vulnerable to an improper certificate validation bug which could cause Argo CD to trust a malicious (or otherwise untrustworthy) OpenID Connect (OIDC) provider. A patch for this vulnerability has been released in Argo CD versions 2.4.5, 2.3.6, and 2.2.11. There are no complete workarounds, but a partial workaround is available. Those who use an external OIDC provider (not the bundled Dex instance), can mitigate the issue by setting the oidc.config.rootCA field in the argocd-cm ConfigMap. This mitigation only forces certificate validation when the API server handles login flows. It does not force certificate verification when verifying tokens on API calls.

Affected Versions

All versions starting from 0.4.0 before 2.2.11, all versions starting from 2.3.0 before 2.3.6, all versions starting from 2.4.0 before 2.4.5

Solution

Upgrade to versions 2.2.11, 2.3.6, 2.4.5 or above.

Last Modified

2022-07-24

source