CVE-2022-31053

Improper Verification of Cryptographic Signature in go/github.com/biscuit-auth/biscuit-go

Identifiers

GHSA-75rw-34q6-72cr, CVE-2022-31053

Package Slug

go/github.com/biscuit-auth/biscuit-go

Vulnerability

Improper Verification of Cryptographic Signature

Description

Biscuit is an authentication and authorization token for microservices architectures. The Biscuit specification version 1 contains a vulnerable algorithm that allows malicious actors to forge valid ?-signatures. Such an attack would allow an attacker to create a token with any access level. The version 2 of the specification mandates a different algorithm than gamma signatures and as such is not affected by this vulnerability. The Biscuit implementations in Rust, Haskell, Go, Java and Javascript all have published versions following the v2 specification. There are no known workarounds for this issue.

Affected Versions

All versions before 2.0

Solution

Upgrade to version 2.0 or above.

Last Modified

2022-07-24

source