CVE-2022-31030

Uncontrolled Resource Consumption in go/github.com/containerd/containerd

Identifiers

CVE-2022-31030, GHSA-5ffw-gxpp-mxpf

Package Slug

go/github.com/containerd/containerd

Vulnerability

Uncontrolled Resource Consumption

Description

containerd is an open source container runtime. A bug was found in the containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the ExecSync API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; ExecSync may be used when running probes or when executing processes via an "exec" facility. This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used.

Affected Versions

All versions before 1.5.13, all versions starting from 1.6.0 before 1.6.6

Solution

Upgrade to versions 1.5.13, 1.6.6 or above.

Last Modified

2022-06-17

source