CVE-2022-32563

Improper Certificate Validation in go/github.com/couchbase/sync_gateway/db

Identifiers

CVE-2022-32563

Package Slug

go/github.com/couchbase/sync_gateway/db

Vulnerability

Improper Certificate Validation

Description

An issue was discovered in Couchbase Sync Gateway 3.x before 3.0.2. Admin credentials are not verified when using X.509 client-certificate authentication from Sync Gateway to Couchbase Server. When Sync Gateway is configured to authenticate with Couchbase Server using X.509 client certificates, the admin credentials provided to the Admin REST API are ignored, resulting in privilege escalation for unauthenticated users. The Public REST API is not impacted by this issue. A workaround is to replace X.509 certificate based authentication with Username and Password authentication inside the bootstrap configuration.

Affected Versions

All versions starting from 3.0.0 before 3.0.2

Solution

Upgrade to version 3.0.2 or above.

Last Modified

2022-06-19

source