CVE-2022-31145

Insufficient Session Expiration in go/github.com/flyteorg/flyteadmin

Identifiers

GHSA-qwrj-9hmp-gpxh, CVE-2022-31145

Package Slug

go/github.com/flyteorg/flyteadmin

Vulnerability

Insufficient Session Expiration

Description

FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. In versions 1.1.30 and prior, authenticated users using an external identity provider can continue to use Access Tokens and ID Tokens even after they expire. Users who use FlyteAdmin as the OAuth2 Authorization Server are unaffected by this issue. A patch is available on the master branch of the repository. As a workaround, rotating signing keys immediately will invalidate all open sessions and force all users to attempt to obtain new tokens. Those who use this workaround should continue to rotate keys until FlyteAdmin has been upgraded and hide FlyteAdmin deployment ingress URL from the internet.

Affected Versions

All versions before 1.1.30

Solution

Upgrade to version 1.1.30 or above.

Last Modified

2022-07-24

source