CVE-2022-31121

Improper Input Validation in go/github.com/hyperledger/fabric/orderer/common/cluster

Identifiers

GHSA-72x4-cq6r-jp4p, CVE-2022-31121

Package Slug

go/github.com/hyperledger/fabric/orderer/common/cluster

Vulnerability

Improper Input Validation

Description

Hyperledger Fabric is a permissioned distributed ledger framework. In affected versions if a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. A fix has been added in commit 0f1835949 which checks for missing consensus messages and returns an error to the consensus client should the message be missing. Users are advised to upgrade to versions 2.2.7 or v2.4.5. There are no known workarounds for this issue.

Affected Versions

All versions before 2.2.7, all versions starting from 2.3.0 before 2.4.5

Solution

Upgrade to versions 2.2.7, 2.4.5 or above.

Last Modified

2022-07-24

source