CVE-2022-31075

Uncontrolled Resource Consumption in go/github.com/kubeedge/kubeedge

Identifiers

GHSA-x3px-2p95-f6jr, CVE-2022-31075

Package Slug

go/github.com/kubeedge/kubeedge

Vulnerability

Uncontrolled Resource Consumption

Description

KubeEdge is an open source system for extending native containerized application orchestration capabilities to hosts at Edge. Prior to versions 1.11.1, 1.10.2, and 1.9.4, EdgeCore may be susceptible to a DoS attack on CloudHub if an attacker was to send a well-crafted HTTP request to /edge.crt. If an attacker can send a well-crafted HTTP request to CloudHub, and that request has a very large body, that request can crash the HTTP service through a memory exhaustion vector. The request body is being read into memory, and a body that is larger than the available memory can lead to a successful attack. Because the request would have to make it through authorization, only authorized users may perform this attack. The consequence of the exhaustion is that CloudHub will be in denial of service. KubeEdge is affected only when users enable the CloudHub module in the file cloudcore.yaml. This bug has been fixed in Kubeedge 1.11.1, 1.10.2, and 1.9.4. As a workaround, disable the CloudHub switch in the config file cloudcore.yaml.

Affected Versions

All versions before 1.9.4, all versions starting from 1.10.0 before 1.10.2, all versions starting from 1.11.0 before 1.11.1

Solution

Upgrade to versions 1.10.2, 1.11.1, 1.9.4 or above.

Last Modified

2022-07-24

source