CVE-2022-2401

Exposure of Sensitive Information to an Unauthorized Actor in go/github.com/mattermost/mattermost-server/v6

Identifiers

GHSA-7ggc-5r84-xf54, CVE-2022-2401

Package Slug

go/github.com/mattermost/mattermost-server/v6

Vulnerability

Exposure of Sensitive Information to an Unauthorized Actor

Description

Unrestricted information disclosure of all users in Mattermost version 6.7.0 and earlier allows team members to access some sensitive information by directly accessing the APIs.

Affected Versions

All versions before 6.3.9, all versions starting from 6.4.0 before 6.5.2, all versions starting from 6.6.0 before 6.6.2, version 6.7.0

Solution

Upgrade to versions 6.3.9, 6.5.2, 6.6.2, 6.7.1 or above.

Last Modified

2022-07-24

source