CVE-2022-27664

golang.org/x/net/http2 Denial of Service vulnerability in go/golang.org/x/net/http2

Identifiers

GHSA-69cg-p879-7622, CVE-2022-27664

Package Slug

go/golang.org/x/net/http2

Vulnerability

golang.org/x/net/http2 Denial of Service vulnerability

Description

In net/http in Go before 1.18.6 and 1.19.x before 1.19.1, attackers can cause a denial of service because an HTTP/2 connection can hang during closing if shutdown were preempted by a fatal error.

Affected Versions

All versions before 0.0.0-20220906165146-f3363e06e74c

Solution

Upgrade to version 0.0.0-20220906165146-f3363e06e74c or above.

Last Modified

2023-01-18

source