CVE-2016-15011

Improper Restriction of XML External Entity Reference in maven/be.e_contract.dssp/dssp-client

Identifiers

GHSA-77cc-w3wm-6whp, CVE-2016-15011

Package Slug

maven/be.e_contract.dssp/dssp-client

Vulnerability

Improper Restriction of XML External Entity Reference

Description

A vulnerability classified as problematic was found in e-Contract dssp up to 1.3.1. Affected by this vulnerability is the function checkSignResponse of the file dssp-client/src/main/java/be/e_contract/dssp/client/SignResponseVerifier.java. The manipulation leads to xml external entity reference. Upgrading to version 1.3.2 is able to address this issue. The name of the patch is ec4238349691ec66dd30b416ec6eaab02d722302. It is recommended to upgrade the affected component. The identifier VDB-217549 was assigned to this vulnerability.

Affected Versions

All versions before 1.3.2

Solution

Upgrade to version 1.3.2 or above.

Last Modified

2023-01-13

source