CVE-2021-25738

Improper Input Validation in maven/io.kubernetes/client-java

Identifiers

CVE-2021-25738

Package Slug

maven/io.kubernetes/client-java

Vulnerability

Improper Input Validation

Description

Loading specially-crafted yaml with the Kubernetes Java Client library can lead to code execution.

Affected Versions

All versions up to 9.0.2, all versions starting from 10.0.0 up to 10.0.1, all versions starting from 11.0.0 before 11.0.2

Solution

Upgrade to versions 9.0.3, 11.0.2 or above.

Last Modified

2021-10-19

source