CVE-2023-26464

Deserialization of Untrusted Data in maven/log4j/log4j

Identifiers

CVE-2023-26464

Package Slug

maven/log4j/log4j

Vulnerability

Deserialization of Untrusted Data

Description

** UNSUPPORTED WHEN ASSIGNED ** When using the Chainsaw or SocketAppender components with Log4j 1.x on JRE less than 1.7, an attacker that manages to cause a logging entry involving a specially-crafted (ie, deeply nested) hashmap or hashtable (depending on which logging component is in use) to be processed could exhaust the available memory in the virtual machine and achieve Denial of Service when the object is deserialized. This issue affects Apache Log4j before 2. Affected users are recommended to update to Log4j 2.x. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Affected Versions

All versions starting from 1.0.4 before 2.0

Solution

Upgrade to version 2.0 or above.

Last Modified

2023-03-16

source