CVE-2022-21363

Improper Handling of Insufficient Permissions or Privileges in MySQL Connectors Java in maven/mysql/mysql-connector-java

Identifiers

GHSA-g76j-4cxx-23h9, CVE-2022-21363

Package Slug

maven/mysql/mysql-connector-java

Vulnerability

Improper Handling of Insufficient Permissions or Privileges in MySQL Connectors Java

Description

Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/J). Supported versions that are affected are 8.0.27 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks of this vulnerability can result in takeover of MySQL Connectors. CVSS 3.1 Base Score 6.6 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (.

Affected Versions

All versions up to 8.0.27

Solution

Upgrade to version 8.0.28 or above.

Last Modified

2022-06-21

source