CVE-2011-4905

Denial of Service in Apache ActiveMQ in maven/org.apache.activemq/activemq-core

Identifiers

GHSA-9wcx-326r-7j7w, CVE-2011-4905

Package Slug

maven/org.apache.activemq/activemq-core

Vulnerability

Denial of Service in Apache ActiveMQ

Description

Apache ActiveMQ before 5.6.0 allows remote attackers to cause a denial of service (file-descriptor exhaustion and broker crash or hang) by sending many openwire failover:tcp:// connection requests.

Affected Versions

All versions before 5.6.0

Solution

Upgrade to version 5.6.0 or above.

Last Modified

2022-07-24

source