CVE-2021-36373

Uncontrolled Resource Consumption in maven/org.apache.ant/ant

Identifier

CVE-2021-36373

Package Slug

maven/org.apache.ant/ant

Vulnerability

Uncontrolled Resource Consumption

Description

When reading a specially crafted TAR archive an Apache Ant build can be made to allocate large amounts of memory that finally leads to an out of memory error, even for small inputs. This can be used to disrupt builds using Apache Ant.

Affected Versions

All versions starting from 1.9.0 before 1.9.16, all versions starting from 1.10.0 before 1.10.11

Solution

Upgrade to versions 1.9.16, 1.10.11 or above.

Last Modified

2021-07-17

source