CVE-2022-25167

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') in maven/org.apache.flume/flume-parent

Identifiers

GHSA-x5m7-rwfx-w7qm, CVE-2022-25167

Package Slug

maven/org.apache.flume/flume-parent

Vulnerability

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Description

Apache Flume versions 1.4.0 through 1.9.0 is vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

Affected Versions

All versions starting from 1.4.0 before 1.10.0

Solution

Upgrade to version 1.10.0 or above.

Last Modified

2022-06-17

source