CVE-2021-36774

Exposure of Resource to Wrong Sphere in maven/org.apache.kylin/kylin

Identifiers

CVE-2021-36774

Package Slug

maven/org.apache.kylin/kylin

Vulnerability

Exposure of Resource to Wrong Sphere

Description

Apache Kylin allows users to read data from other database systems using JDBC. The MySQL JDBC driver supports certain properties, which, if left unmitigated, can allow an attacker to execute arbitrary code from a hacker-controlled malicious MySQL server within Kylin server processes. This issue affects Apache Kylin 2 and prior versions; Apache Kylin 3 and prior versions.

Affected Versions

All versions starting from 2.0.0 up to 2.6.6, all versions starting from 3.0.0 up to 3.1.2

Solution

Upgrade to versions 3.1.3 or above.

Last Modified

2022-01-14

source