Insufficiently Protected Credentials in maven/org.apache.kylin/kylin-core-common


GHSA-3vvc-v8c2-43r7, CVE-2023-29055

Package Slug



Insufficiently Protected Credentials


In Apache Kylin version 2.0.0 to 4.0.3, there is a Server Config web interface that displays the content of file '', that may contain serverside credentials. When the kylin service runs over HTTP (or other plain text protocol), it is possible for network sniffers to hijack the HTTP payload and get access to the content of and potentially the containing credentials.

To avoid this threat, users are recommended to 

  • Always turn on HTTPS so that network payload is encrypted.

  • Avoid putting credentials in, or at least not in plain text.

  • Use network firewalls to protect the serverside such that it is not accessible to external attackers.

  • Upgrade to version Apache Kylin 4.0.4, which filters out the sensitive content that goes to the Server Config web interface.

Affected Versions

All versions starting from 2.0.0 before 4.0.4


Upgrade to version 4.0.4 or above.

Last Modified