Identifier

CVE-2020-9491

Package Slug

maven/org.apache.nifi/nifi

Vulnerability

Inadequate Encryption Strength

Description

In Apache NiFi, the NiFi UI and API were protected by mandating TLS v1.2, as well as listening connections established by processors like ListenHTTP, HandleHttpRequest, etc. However, intracluster communication such as cluster request replication, Site-to-Site, and load balanced queues continued to support TLS v1.0 or v1.1.

Affected Versions

All versions starting from 1.0.0 up to 1.11.4

Solution

Upgrade to version 1.12.0 or above.

Last Modified

2020-10-06

source