CVE-2022-26850

Insufficiently Protected Credentials in maven/org.apache.nifi/nifi-single-user-utils

Identifiers

GHSA-rvp4-r3g6-8hxq, CVE-2022-26850

Package Slug

maven/org.apache.nifi/nifi-single-user-utils

Vulnerability

Insufficiently Protected Credentials

Description

When creating or updating credentials for single-user access, Apache NiFi wrote a copy of the Login Identity Providers configuration to the operating system temporary directory. On most platforms, the operating system temporary directory has global read permissions. NiFi immediately moved the temporary file to the final configuration directory, which significantly limited the window of opportunity for access. NiFi 1.16.0 includes updates to replace the Login Identity Providers configuration without writing a file to the operating system temporary directory.

Affected Versions

All versions up to 1.15.3

Solution

Upgrade to version 1.16 or above.

Last Modified

2022-06-21

source