Observable Discrepancy in maven/org.apache.pulsar/pulsar-broker



Package Slug



Observable Discrepancy


Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the saslJaasServerRoleTokenSignerSecretPath file.

Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker.

2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions.

For additional details on this attack vector, please refer to .

Affected Versions

All versions up to 2.10.5, all versions starting from 2.11.0 before 2.11.3, all versions starting from 3.0.0 before 3.0.2, version 3.1.0


Upgrade to versions 2.11.3, 3.0.2, 3.1.1 or above.

Last Modified