CVE-2012-4446

Improper Authentication in maven/org.apache.qpid/qpid-client

Identifiers

GHSA-mrgh-6x42-x6xf, CVE-2012-4446

Package Slug

maven/org.apache.qpid/qpid-client

Vulnerability

Improper Authentication

Description

The default configuration for Apache Qpid 0.20 and earlier, when the federation_tag attribute is enabled, accepts AMQP connections without checking the source user ID, which allows remote attackers to bypass authentication and have other unspecified impact via an AMQP request.

Affected Versions

All versions before 0.20

Solution

Upgrade to version 0.20 or above.

Last Modified

2022-07-25

source