CVE-2023-22602

Interpretation Conflict in maven/org.apache.shiro/shiro-root

Identifiers

GHSA-7cxr-h8wm-fg4c, CVE-2023-22602

Package Slug

maven/org.apache.shiro/shiro-root

Vulnerability

Interpretation Conflict

Description

When using Apache Shiro before 1.11.0 together with Spring Boot 2.6+, a specially crafted HTTP request may cause an authentication bypass. The authentication bypass occurs when Shiro and Spring Boot are using different pattern-matching techniques. Both Shiro and Spring Boot < 2.6 default to Ant style pattern matching. Mitigation: Update to Apache Shiro 1.11.0, or set the following Spring Boot configuration value: spring.mvc.pathmatch.matching-strategy = ant_path_matcher

Affected Versions

All versions before 1.11.0

Solution

Upgrade to version 1.11.0 or above.

Last Modified

2023-01-23

source