CVE-2022-36127

Denial of service in maven/org.apache.skywalking/server-storage-plugin

Identifiers

CVE-2022-36127

Package Slug

maven/org.apache.skywalking/server-storage-plugin

Vulnerability

Denial of service

Description

The vulnerability will cause NodeJS services that has this agent installed to be unavailable if the OAP is unhealthy and NodeJS agent can't establish the connection.

Affected Versions

All versions before 0.5.1

Solution

Upgrade to version 6.0.0-alpha or above. Note: 6.0.0-alpha may be an unstable version. Use caution.

Last Modified

2022-07-25

source