CVE-2008-5515

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in maven/org.apache.tomcat/tomcat

Identifiers

GHSA-9737-qmgc-hfr9, CVE-2008-5515

Package Slug

maven/org.apache.tomcat/tomcat

Vulnerability

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Description

Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, 6.0.0 through 6.0.18, and possibly earlier versions normalizes the target pathname before filtering the query string when using the RequestDispatcher method, which allows remote attackers to bypass intended access restrictions and conduct directory traversal attacks via .. (dot dot) sequences and the WEB-INF directory in a Request.

Affected Versions

All versions starting from 4.1.0 before 4.1.40, all versions starting from 5.5.0 before 5.5.28, all versions starting from 6.0.0 before 6.0.19

Solution

Upgrade to versions 4.1.40, 5.5.28, 6.0.20 or above.

Last Modified

2022-06-10

source