CVE-2009-0781

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in maven/org.apache.tomcat/tomcat

Identifiers

GHSA-j788-fx57-99wp, CVE-2009-0781

Package Slug

maven/org.apache.tomcat/tomcat

Vulnerability

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

Cross-site scripting (XSS) vulnerability in jsp/cal/cal2.jsp in the calendar application in the examples web application in Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18 allows remote attackers to inject arbitrary web script or HTML via the time parameter, related to "invalid HTML."

Affected Versions

All versions starting from 4.1.0 up to 4.1.39, all versions starting from 5.5.0 up to 5.5.27, all versions starting from 6.0.0 up to 6.0.18

Solution

Upgrade to version 6.0.20 or above.

Last Modified

2022-06-19

source