CVE-2009-2901

Improper Authentication in Apache Tomcat in maven/org.apache.tomcat/tomcat

Identifiers

GHSA-hjfh-7c4v-7q8h, CVE-2009-2901

Package Slug

maven/org.apache.tomcat/tomcat

Vulnerability

Improper Authentication in Apache Tomcat

Description

The autodeployment process in Apache Tomcat 5.5.0 through 5.5.28 and 6.0.0 through 6.0.20, when autoDeploy is enabled, deploys appBase files that remain from a failed undeploy, which might allow remote attackers to bypass intended authentication requirements via HTTP requests.

Affected Versions

All versions starting from 5.5.0 up to 5.5.28, all versions starting from 6.0.0 up to 6.0.20

Solution

Upgrade to versions 5.5.29, 6.0.24 or above.

Last Modified

2022-06-19

source