CVE-2010-1157

Exposure of Sensitive Information to an Unauthorized Actor in maven/org.apache.tomcat/tomcat

Identifiers

GHSA-w6q7-ww2x-7gm3, CVE-2010-1157

Package Slug

maven/org.apache.tomcat/tomcat

Vulnerability

Exposure of Sensitive Information to an Unauthorized Actor

Description

Apache Tomcat 5.5.0 through 5.5.29 and 6.0.0 through 6.0.26 might allow remote attackers to discover the server's hostname or IP address by sending a request for a resource that requires (1) BASIC or (2) DIGEST authentication, and then reading the realm field in the WWW-Authenticate header in the reply.

Affected Versions

All versions starting from 5.5.0 up to 5.5.29, all versions starting from 6.0.0 up to 6.0.26

Solution

Upgrade to versions 5.5.30, 6.0.28 or above.

Last Modified

2022-06-19

source