CVE-2011-2526

Improper Input Validation in maven/org.apache.tomcat/tomcat

Identifiers

GHSA-9ggm-7897-x4mg, CVE-2011-2526

Package Slug

maven/org.apache.tomcat/tomcat

Vulnerability

Improper Input Validation

Description

Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.19, when sendfile is enabled for the HTTP APR or HTTP NIO connector, does not validate certain request attributes, which allows local users to bypass intended file access restrictions or cause a denial of service (infinite loop or JVM crash) by leveraging an untrusted web application.

Affected Versions

All versions before 5.5.34, all versions starting from 6.0.0 before 6.0.33, all versions starting from 7.0.0 before 7.0.19

Solution

Upgrade to versions 5.5.34, 6.0.33, 7.0.19 or above.

Last Modified

2022-07-25

source