CVE-2011-4858

Improper Input Validation in Apache Tomcat in maven/org.apache.tomcat/tomcat

Identifiers

GHSA-wr3m-gw98-mc3j, CVE-2011-4858

Package Slug

maven/org.apache.tomcat/tomcat

Vulnerability

Improper Input Validation in Apache Tomcat

Description

Apache Tomcat before 5.5.35, 6.x before 6.0.35, and 7.x before 7.0.23 computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.

Affected Versions

All versions starting from 5.5.0 before 5.5.35, all versions starting from 6.0.0 before 6.0.35, all versions starting from 7.0.0 before 7.0.23

Solution

Upgrade to versions 5.5.35, 6.0.35, 7.0.23 or above.

Last Modified

2022-07-25

source