CVE-2011-5062

Improper Authentication in Apache Tomcat in maven/org.apache.tomcat/tomcat

Identifiers

GHSA-4f7h-9j2x-cmr4, CVE-2011-5062

Package Slug

maven/org.apache.tomcat/tomcat

Vulnerability

Improper Authentication in Apache Tomcat

Description

The HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.12 does not check qop values, which might allow remote attackers to bypass intended integrity-protection requirements via a qop=auth value, a different vulnerability than CVE-2011-1184.

Affected Versions

All versions starting from 5.5.0 before 5.5.34, all versions starting from 6.0.0 before 6.0.33, all versions starting from 7.0.0 before 7.0.12

Solution

Upgrade to versions 5.5.34, 6.0.33, 7.0.12 or above.

Last Modified

2022-07-25

source