CVE-2011-5063

Improper Authentication in maven/org.apache.tomcat/tomcat

Identifiers

GHSA-hffm-fqv4-w27r, CVE-2011-5063

Package Slug

maven/org.apache.tomcat/tomcat

Vulnerability

Improper Authentication

Description

The HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.12 does not check realm values, which might allow remote attackers to bypass intended access restrictions by leveraging the availability of a protection space with weaker authentication or authorization requirements, a different vulnerability than CVE-2011-1184.

Affected Versions

All versions starting from 5.5.0 before 5.5.34, all versions starting from 6.0.0 before 6.0.33, all versions starting from 7.0.0 before 7.0.12

Solution

Upgrade to versions 5.5.34, 6.0.33, 7.0.12 or above.

Last Modified

2022-07-25

source