CVE-2012-5886

Improper Authentication in maven/org.apache.tomcat/tomcat

Identifiers

GHSA-9xrj-439h-62hg, CVE-2012-5886

Package Slug

maven/org.apache.tomcat/tomcat

Vulnerability

Improper Authentication

Description

The HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x before 5.5.36, 6.x before 6.0.36, and 7.x before 7.0.30 caches information about the authenticated user within the session state, which makes it easier for remote attackers to bypass authentication via vectors related to the session ID.

Affected Versions

All versions starting from 5.5.0 before 5.5.36, all versions starting from 6.0.0 before 6.0.36, all versions starting from 7.0.0 before 7.0.30

Solution

Upgrade to versions 5.5.36, 6.0.36, 7.0.30 or above.

Last Modified

2022-07-25

source