CVE-2022-20616

Incorrect Permission Assignment for Critical Resource in maven/org.jenkins-ci.plugins/credentials

Identifiers

GHSA-gqm2-2gcx-p88w, CVE-2022-20616

Package Slug

maven/org.jenkins-ci.plugins/credentials

Vulnerability

Incorrect Permission Assignment for Critical Resource

Description

Jenkins Credentials Binding Plugin 1.27 and earlier does not perform a permission check in a method implementing form validation, allowing attackers with Overall/Read access to validate if a credential ID refers to a secret file credential and whether it's a zip file.

Affected Versions

All versions up to 1.27

Solution

Upgrade to version 1.28 or above.

Last Modified

2022-06-21

source