CVE-2022-25178

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in maven/org.jenkins-ci.plugins.workflow/workflow-cps-global-lib

Identifiers

GHSA-5hfv-mg5x-mv32, CVE-2022-25178

Package Slug

maven/org.jenkins-ci.plugins.workflow/workflow-cps-global-lib

Vulnerability

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Description

Jenkins Pipeline: Shared Groovy Libraries Plugin 552.vd9cc05b8a2e1 and earlier does not restrict the names of resources passed to the libraryResource step, allowing attackers able to configure Pipelines permission to read arbitrary files on the Jenkins controller file system.

Affected Versions

All versions up to 552.vd9cc05b8a2e1

Solution

Upgrade to version 561.va_ce0de3c2d69 or above.

Last Modified

2022-06-21

source