CVE-2022-25181

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') in maven/org.jenkins-ci.plugins.workflow/workflow-cps-global-lib

Identifiers

GHSA-7w2w-fwpf-9m4h, CVE-2022-25181

Package Slug

maven/org.jenkins-ci.plugins.workflow/workflow-cps-global-lib

Vulnerability

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Description

A sandbox bypass vulnerability in Jenkins Pipeline: Shared Groovy Libraries Plugin 552.vd9cc05b8a2e1 and earlier allows attackers with Item/Configure permission to execute arbitrary code in the context of the Jenkins controller JVM through crafted SCM contents, if a global Pipeline library already exists.

Affected Versions

All versions up to 552.vd9cc05b8a2e1

Solution

Upgrade to version 561.va_ce0de3c2d69 or above.

Last Modified

2022-06-21

source