CVE-2022-25183

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') in maven/org.jenkins-ci.plugins.workflow/workflow-cps-global-lib

Identifiers

GHSA-pfwp-q984-w7wh, CVE-2022-25183

Package Slug

maven/org.jenkins-ci.plugins.workflow/workflow-cps-global-lib

Vulnerability

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Description

Jenkins Pipeline: Shared Groovy Libraries Plugin 552.vd9cc05b8a2e1 and earlier uses the names of Pipeline libraries to create cache directories without any sanitization, allowing attackers with Item/Configure permission to execute arbitrary code in the context of the Jenkins controller JVM using specially crafted library names if a global Pipeline library configured to use caching already exists.

Affected Versions

All versions up to 552.vd9cc05b8a2e1

Solution

Upgrade to version 561.va_ce0de3c2d69 or above.

Last Modified

2022-06-21

source