CVE-2009-4611

Improper Input Validation in maven/org.mortbay.jetty/jetty

Identifiers

GHSA-6jxp-7g74-2rc3, CVE-2009-4611

Package Slug

maven/org.mortbay.jetty/jetty

Vulnerability

Improper Input Validation

Description

Mort Bay Jetty 6.x through 6.1.22 and 7.0.0 writes backtrace data without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator, related to (1) a string value in the Age parameter to the default URI for the Cookie Dump Servlet in test-jetty-webapp/src/main/java/com/acme/CookieDump.java under cookie/, (2) an alphabetic value in the A parameter to jsp/expr.jsp, or (3) an alphabetic value in the Content-Length HTTP header to an arbitrary application.

Affected Versions

All versions starting from 6.0.0 before 6.1.23, all versions starting from 7.0.0 before 7.0.2

Solution

Upgrade to versions 6.1.23, 7.0.2 or above.

Last Modified

2022-06-13

source