CVE-2021-25959

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in maven/org.opencrx/opencrx-core

Identifier

CVE-2021-25959

Package Slug

maven/org.opencrx/opencrx-core

Vulnerability

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.

Affected Versions

All versions starting from 4.0.0 up to 5.1.0

Solution

Upgrade to version 5.2.0 or above.

Last Modified

2021-10-10

source