CVE-2022-31044

Insufficiently Protected Credentials in maven/org.rundeck/rundeck

Identifiers

GHSA-hprf-rrwq-jm5c, CVE-2022-31044

Package Slug

maven/org.rundeck/rundeck

Vulnerability

Insufficiently Protected Credentials

Description

Rundeck is an open source automation service with a web console, command line tools and a WebAPI. The Key Storage converter plugin mechanism was not enabled correctly in Rundeck 4.2.0 and 4.2.1, resulting in use of the encryption layer for Key Storage possibly not working. Any credentials created or overwritten using Rundeck 4.2.0 or 4.2.1 might result in them being written in plaintext to the backend storage. This affects those using any Storage Converter plugin. Rundeck 4.3.1 and 4.2.2 have fixed the code and upon upgrade will re-encrypt any plain text values. Version 4.3.0 does not have the vulnerability, but does not include the patch to re-encrypt plain text values if 4.2.0 or 4.2.1 were used. To prevent plaintext credentials from being stored in Rundeck 4.2.0/4.2.1, write access to key storage can be disabled via ACLs. After upgrading to 4.3.1 or later, write access can be restored.

Affected Versions

All versions starting from 4.2.0 before 4.2.2, all versions starting from 4.3.0 before 4.3.1

Solution

Upgrade to versions 4.2.2, 4.3.1 or above.

Last Modified

2022-06-19

source