CVE-2016-1000027

Deserialization of Untrusted Data in maven/org.springframework/spring-web

Identifiers

GHSA-4wrc-f8pq-fpqp, CVE-2016-1000027

Package Slug

maven/org.springframework/spring-web

Vulnerability

Deserialization of Untrusted Data

Description

Pivotal Spring Framework through 5.3.16 suffers from a potential remote code execution (RCE) issue if used for Java deserialization of untrusted data. Depending on how the library is implemented within a product, this issue may or not occur, and authentication may be required. NOTE: the vendor's position is that untrusted data is not an intended use case. The product's behavior will not be changed because some users rely on deserialization of trusted data.

Affected Versions

All versions before 3.2.17, all versions starting from 4.0.0 before 4.2.6

Solution

Upgrade to versions 3.2.17, 4.2.6 or above.

Last Modified

2022-11-15

source