CVE-2022-24898

Improper Neutralization in maven/org.xwiki.commons/xwiki-commons-xml

Identifiers

GHSA-m2r5-4w96-qxg5, CVE-2022-24898

Package Slug

maven/org.xwiki.commons/xwiki-commons-xml

Vulnerability

Improper Neutralization

Description

org.xwiki.commons:xwiki-commons-xml is a common module used by other XWiki top level projects. Starting in version 2.7 and prior to versions 12.10.10, 13.4.4, and 13.8-rc-1, it is possible for a script to access any file accessing to the user running XWiki application server with XML External Entity Injection through the XML script service. The problem has been patched in versions 12.10.10, 13.4.4, and 13.8-rc-1. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.

Affected Versions

All versions starting from 2.7 before 12.10.10, all versions starting from 13.0.0 before 13.4.4, all versions starting from 13.5-rc-1 up to 13.7

Solution

Upgrade to versions 12.10.10, 13.4.4, 13.8-rc-1 or above. Note: 13.8-rc-1 may be an unstable version. Use caution.

Last Modified

2022-05-01

source