CVE-2022-34169

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') in maven/xalan/xalan

Identifiers

GHSA-9339-86wc-4qgf, CVE-2022-34169

Package Slug

maven/xalan/xalan

Vulnerability

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Description

The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. The Apache Xalan Java project is dormant and in the process of being retired. No future releases of Apache Xalan Java to address this issue are expected. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.

Affected Versions

All versions up to 2.7.2

Solution

Unfortunately, there is no solution available yet.

Last Modified

2022-07-26

source